PLCGurus.NET Live & Interactive Forum PLC Questions and Answers Rockwell, Allen-Bradley, Stratix @devicepath gives different info on panel view than on workstation

  • This topic has 3 replies, 2 voices, and was last updated 1 year ago by Ken S.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #20600
      Karma: 25
      Rank: Padawan

      I got a CompacLogix 5480 and a Panelview Plus premium 2711 (12″)

      After upgrading the PV firmware to 11 it final talks to the 5480.

      However, the application still compiles with the warning that the shortcut references a unknown device.  I have went threw the RA Knowledge base and apparently this is not a big issue as it is only a warning.  The test application works.

      However, I’m using a text field that pulls in the @devicepath, on the workstation it works as expected it shows the full PLC processor name and the IP path.

      When I load the application to the panel view, it shows something like CIP={insert some crazy numbers here} on

      Is it because the Panel does not recognize the 5480, per the short cut warning?

      Is their an EDS file of sorts I need to install on the Panel View?

      Thanks in advance

      Ken S
        Karma: 172
        Rank: Jedi

        Nothing is needed really, as for the EDS file – you can right click in RsLinx and upload eds to your computer.

        In the panel view program – you should have the mer file (you will need to re-source it back to an apa) load it in your FactoryTalk ME software , in the project tree at the bottom – you will see the communications tab, click that , in the upper right of the screen you will see the network browser much like Rslinx Network version .. Click on your shortcut  in the left hand side of the tree , then in the right tree of device links select the PLC device the shortcut points to. Click Apply on the bottom right ..
        Save your project and load it into the PanelView.. done..

        What application – the logix application or the View Application ? I assume you meant view application and all you need is the network connectivity of the communications tab to point to the device .
        However if EDS is an issue – right click the unknown devices in Rslinx and upload the EDS to your computer .. done..

          Karma: 25
          Rank: Padawan

          Sorry I guess I explained wrong.

          I already built a test app and downloaded.  The design links and runtime links are configured correctly already.

          Its when I run the app on the panel view it does not show the PLC nomenclature, only a bunch of meaningless numbers.  It shows the full nomenclature if a test it on the computer.

          Ken S
            Karma: 172
            Rank: Jedi

            Ok so not looking at a picture of what you have, but in the shortcuts of the communication path – you have assigned the shortcut .

            In your text field on the screen you are attempting to read the @devicepath system reserved word.
            My understanding is that you are just having an issue with the text field reading / displaying the correct value .

            On the workstation you loaded it runs fine.
            When you click test ME runtime application in FT View it runs fine?
            When you run the application on panel view it does not ?

            The EDS is not the issue , again you can test that by right click and upload eds into your system via rslinx.

            I know I have had a similar warning message and error previously – you know when the issue is simple you forget about the fix.

            I think if you look at your text field you need to add a parameter or special symbol, the
            If you created an HMI tag to point to the @devicepath would that HMI tag have the right value ?
            [You can let your PLC read this HMI tag]
            This is to determine if you are reading the correct value or simply not displaying the correct value.

            I think it is a matter of a simple character representation

            Show a screenshot of your configuration for the text field.

          Viewing 4 posts - 1 through 4 (of 4 total)
          • You must be logged in to reply to this topic.

          This website uses cookies.