RSLogix 5000 Fatal Error on IRT8I Module Add

PLCGurus.NET Live & Interactive Forum PLC Questions and Answers Rockwell, Allen-Bradley, Stratix RSLogix 5000 Fatal Error on IRT8I Module Add

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #3158
      Karma: 0
      Rank: Padawan

      Good morning,

      Having an issue I hope someone can offer some guidance on:

      RSLogix 5000 v20.04 (also happened on v20.03)

      Windows 10 PC

      Issue: Attempting to add a 1756-IRT8I Module to a project I am working on. Once I am ready to complete the addition. I get the following errors:

      PS1756ApexAnalogTagExt – Out of Memory

      Error – Couldn’t Create Module


      I have tried updating the module AOP. However, it seems like I have the latest version. Does anyone else have any suggestions? Thanks!


        Karma: 171
        Rank: Jedi


        Hi, I had some troubles with V. 20.04 also. Check out this link to another forum and read through the posts. One gentleman from Canada seems to have a fix for your problem”

        BTW, I have read where V. 20.03 is not something you want to run. It was like an experimental version or a beta version, something like that. I believe I read that if you use 20.03, then only 20.03 can access it, nothing higher will open it. Hope this will help you a little bit. Have a great week.

          Karma: 0
          Rank: Padawan

          I tried following that thread already. Seems he is having somewhat of a different issue than me. I have also tried uninstalling and reinstalling the AOP and EDS Files for that module. Seems to be the only one that this happens on.

            Karma: 13
            Rank: Padawan

            I am facing same issue of “PS1756ApexAnalogTagExt – Out of Memory” while attempting to add “1756-IRT8I” module in RSlogix 5000 v20.01 and Studio 5000 V30.0.

            Did you guys found out any workable solution?


              I’ve not encountered this problem, however, I’ve had some weird things happen when I’ve used a “Reg Cleaner” on my PC. Have any of you run any kind of registry cleaner that could have corrupted some files? I’m looking on the knowledge base and am coming up empty. There is something definitely odd at play here…keep us posted on what you find out!

                Karma: 141
                Rank: Jedi

                I have checked with Rockwell Tech Support on this, and they recommend to update the core AOP’s, not just the individual one for that module.  I’m not sure is this is what you tried, but here are the instructions on how to perform this.  Give this a try and see if it helps your issue.

                This bundle provides easy access to all of the available device profiles without having to install the latest Studio 5000 Logix Designer release.

                The bundle includes all Add-On Profiles (first available bundle included 754) delivered since RSLogix 5000 version 10 through the latest released version of Studio 5000 Logix Designer. This bundle will be updated every time there is a new major release of Studio 5000 Logix Designer.

                • Release notes lists profiles, with device firmware and Studio 5000 Logix Designer version compatibility
                • Select third party profiles are also included
                • Install file size is approx. 1.4GB
                • Compatible with Windows 7 and newer OS only

                Available for download from Product Compatibility and Download Center (PCDC).

                • No tech connect contract is required to download.

                On the PCDC website, click on Find Downloads and search for AOP. Select the Add-On Profiles and click on Downloads in the right pane.

                Note: When you click on the download icon next to the selected files to download (Add-On Profiles All), you might incorrectly need to give your tech connect details. Instead click on the Downloads button.

                On the next page, click on the download icon. The AOP bundle is shown in the middle of the list.

                The release notes contain a list of all included AOPs, supported firmware versions and minimum Studio 5000 version required:


                In the following cases it’s a good idea to start with updating the AOP’s on your workstation to the latest available version:

                • Missing AOP in Studio 5000 Logix Designer
                • Encountering a FATAL ERROR while trying to create, add or edit module properties
                • Being able to ping a device and see it in RSLinx, but getting communication errors in Studio 5000 Logix Designer
              Viewing 6 posts - 1 through 6 (of 6 total)
              • You must be logged in to reply to this topic.