RSLogix 5000 SQO Instruction

https://www.linkev.com/?a_fid=ics-eng
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1033
    Chris NielChris Niel
    Participant
    • Topics: 4
    • Replies: 3
    • Total Posts: 7
    Karma: 11
    Rank: Padawan

    Hi, I’m struggling with a problem around an SQO instruction. I’m not sure what is going on but I’m NOT always getting the correct output into my destination word? I have an array of DINT setup that moves the values into a destination word when a switch activates. Any ideas? Thanks.

    #1034
    Fred GrahamFred Graham
    Keymaster
    • Topics: 15
    • Replies: 158
    • Total Posts: 173

    Hi Chris and welcome back!

    Have you checked to make sure your SQO instruction is not exceeding the amount of elements in the source array?

    Check out my example image, since there is no position 10 in the sqo_test_source tag the data in the sqo_test_dest tag reads (2075180). This is basically garbage data. Care should be taken when setting up an SQO Instruction position, not to exceed the amount of elements in a Source array.

    Attachments:
    You must be logged in to view attached files.
    #1038
    Chris NielChris Niel
    Participant
    • Topics: 4
    • Replies: 3
    • Total Posts: 7
    Karma: 11
    Rank: Padawan

    That was it. Thanks!

    #1041
    Fred GrahamFred Graham
    Keymaster
    • Topics: 15
    • Replies: 158
    • Total Posts: 173

    Great!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.